在向API请求时发生了一个HTTP错误

自打菠萝罐头换成typecho以后,很久没有去碰wordpress。 今天装了3.1.2 版本的wordpress,在后台想安装主题的时候,出现 “在向API请求时发生了一个HTTP错误”,最开始以为是文件夹权限的问题,改成777以后发现问题还是存在。 最后发现这个问题是网络连接超时引起,大概也是论主机的,修改wp-includes/class-http.php , 搜索timeout,找到这一行: ‘timeout’ => apply_filters( ‘http_request_timeout’, 5) 默认网络超时时间是5秒,短短的5秒稍纵即逝,改成30秒甚至1分钟,这个错误基本上就不再出现了。

评论